Increased latency impacting several customers in us-east-1

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Apr 05, 2023 - 00:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2023 - 20:02 UTC

Investigating

We are investigating increased latency impacting several customers in us-east-1.
Posted Apr 04, 2023 - 14:00 UTC
This incident affected: Amazon Web Services (AWS) (us-east-1).