Some customers may have incorrectly received a "credit expiry notification"

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 22:23 UTC

Monitoring

A fix has been implemented and we are currently working on sending out correction emails to affected customers.
Posted Sep 18, 2026 - 17:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 18, 2026 - 16:00 UTC

Investigating

We are currently investigating this issue.
Posted Sep 18, 2026 - 15:54 UTC
This incident affected: Global Services (Billing).