Some customers in aws us-west-2 may experience elevated visibility persistence latencies.

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 02:25 UTC

Update

We are continuing to investigate this issue.
Posted Apr 02, 2025 - 01:52 UTC

Investigating

Some customers in aws us-west-2 may experience elevated visibility persistence latencies.
Posted Apr 02, 2025 - 01:50 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).