A small number of customers in AWS experienced API timeouts.

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 01:30 UTC

Monitoring

A small number of customers in AWS experienced API timeouts. We are monitoring the issue.
Posted Mar 19, 2026 - 00:47 UTC
This incident affected: Amazon Web Services (AWS) (ap-northeast-1, ap-northeast-2, ap-south-1, ap-south-2, ap-southeast-1, ap-southeast-2, ca-central-1, eu-central-1, eu-west-1, eu-west-2, sa-east-1, us-east-1, us-east-2, us-west-2).