Some customers in AWS eu-west-1 may experience elevated latencies

Incident Report for Temporal

Resolved

We have continued to see normal activity in this region with latencies holding at pre-incident levels. This incident is now resolved.
Posted Jul 20, 2026 - 20:50 UTC

Monitoring

Our engineering has implemented a fix and we are seeing normal service return to this region. We are continuing to monitor.
Posted Jul 20, 2026 - 19:50 UTC

Identified

As of 17:53 UTC our engineering team has identified the issue and is actively working to restore normal service. We will provide another update as more information becomes available.
Posted Jul 20, 2026 - 19:11 UTC

Update

We are continuing to investigate this issue.
Posted Jul 20, 2026 - 14:18 UTC

Investigating

Some customers in AWS eu-west-1 may experience elevated latencies starting 13:47 UTC time.
Posted Jul 20, 2026 - 13:47 UTC
This incident affected: Amazon Web Services (AWS) (eu-west-1).