Customers in AWS us-west-2 may experience elevated API latencies

Incident Report for Temporal

Resolved

We have continued to see normal activity in this region, with latencies holding at pre-incident levels.
This incident is now resolved.
Posted Aug 13, 2026 - 12:27 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 13, 2026 - 12:09 UTC

Monitoring

The incident has been mitigated, and we are monitoring
Posted Aug 13, 2026 - 12:09 UTC

Investigating

Customers in AWS us-west-2 may experience elevated API latencies
Posted Aug 13, 2026 - 11:47 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).