Some customers in AWS us-east-2 may have experienced elevated API latencies and errors

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Jul 05, 2026 - 19:38 UTC

Monitoring

Some customers in AWS us-east-2 may have experienced elevated API latencies and errors between 17:57 and 18:16 UTC
Posted Jul 05, 2026 - 18:41 UTC
This incident affected: Amazon Web Services (AWS) (us-east-2).