Some customers in us-west-2 may experience elevated rate of API errors and high latency

Incident Report for Temporal

Update

API latencies and error rates have remained stable after a fix in history service and we continue to monitor the situation.
Posted May 05, 2026 - 09:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 05, 2026 - 07:50 UTC

Update

We continue working to mitigate the issue.
Posted May 05, 2026 - 07:39 UTC

Identified

We are working to mitigate the issue. Error rates are recovering.
Posted May 05, 2026 - 07:12 UTC

Update

This is still in investigation
Posted May 05, 2026 - 06:22 UTC

Investigating

We are currently investigating the issue.
Posted May 05, 2026 - 05:43 UTC
This incident affects: Amazon Web Services (AWS) (us-west-2).