Some customers in AWS us-west-2 may experience degraded visibility performance

Incident Report for Temporal

Resolved

We're seeing recovery on our end and errors and latencies on Visibility APIs have dropped. We will continue to monitor this but the incident is mitigated and resolved.
Posted Jul 20, 2026 - 19:14 UTC

Monitoring

We have identified the issue and implemented mitigation efforts. We are currently monitoring.
Posted Jul 20, 2026 - 18:45 UTC

Investigating

We are currently investigating this issue.
Posted Jul 20, 2026 - 18:29 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).