Some customers in AWS us-west-2 may experience degraded visibility performance

Incident Report for Temporal

Resolved

This incident has been resolved. Visibility performance has been restored.
Posted Jul 23, 2026 - 19:59 UTC

Monitoring

The issue has been identified and mitigations have been put in place. We are continuing to monitor.
Posted Jul 23, 2026 - 19:32 UTC

Investigating

We are currently investigating this issue.
Posted Jul 23, 2026 - 19:11 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).