Some customers in AWS us-east-1 may experience elevated rate of API errors and elevated latencies

Incident Report for Temporal

Investigating

We are currently investigating the root cause of the elevated latencies and API errors observed in AWS us-east-1 and are working to mitigate any recurring impact.
Posted Jul 08, 2026 - 16:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 16:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 08, 2026 - 15:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 15:28 UTC

Investigating

Some customers in AWS us-east-1 may experience elevated rate of API errors and elevated latencies.
Posted Jul 08, 2026 - 14:26 UTC
This incident affects: Amazon Web Services (AWS) (us-east-1).