AWS has resolved the underlying infrastructure issues in us-east-1. We have marked the region as healthy and are failing our AWS us-east-1 primary multi-region replication customers back into this region.
Posted May 09, 2026 - 03:56 UTC
Update
AWS continues to work to resolve the underlying infrastructure issues in us-east-1. We continue to monitor our service closely, and we have not observed any new impact.
Posted May 08, 2026 - 17:37 UTC
Update
We continue to monitor the situation and the service stability has been maintained.
Posted May 08, 2026 - 12:29 UTC
Monitoring
We continue to work closely with AWS and monitor the situation. There are no new developments at this time, and service remains stable.
Posted May 08, 2026 - 09:27 UTC
Update
We continue to stay closely aligned with AWS and are actively monitoring the environment to ensure ongoing stability.
Posted May 08, 2026 - 07:43 UTC
Update
We are continuing to work closely with AWS as they address the underlying issue and are actively monitoring impacted namespaces for stability. We have also confirmed multi-region replication-enabled namespaces are in their expected replication configuration.
Posted May 08, 2026 - 03:40 UTC
Update
We are continuing to work closely with AWS as they address the underlying issue. We are also actively monitoring the health of impacted namespaces.