Some customers in AWS us-east-1 experienced a small number of gRPC UNIMPLEMENTED errors

Incident Report for Temporal

Resolved

The service has remained stable since the initial behavior was observed 5/28 19:40 to 20:05 UTC.

A permanent fix for the region is now in-progress.
Posted May 29, 2026 - 22:14 UTC

Update

The service continues to operate normally. We will provide additional updates as they become available.
Posted May 29, 2026 - 10:48 UTC

Update

The service remains stable. We are continuing to monitor closely while work progresses on a permanent fix to prevent recurrence.
Posted May 29, 2026 - 02:11 UTC

Update

We have confirmed the service is now stable and are now working to ensure a permanent fix is in place to prevent any recurrence.

We will continue to monitor for errors until the fix is deployed.
Posted May 28, 2026 - 23:17 UTC

Update

Service has remained stable and we are continuing to monitor the situation.

We will continue to provide updates as they become available.
Posted May 28, 2026 - 22:14 UTC

Monitoring

The gRPC UNIMPLEMENTED errors previously observed have been mitigated.

We are continuing to monitor the situation and are working towards a permanent fix at this time.
Posted May 28, 2026 - 21:00 UTC

Identified

Some customers in AWS us-east-1 experienced a small number of gRPC UNIMPLEMENTED errors today from 19:40 to 20:05 UTC.

We have identified a root cause and are currently working towards a permanent fix.
Posted May 28, 2026 - 20:22 UTC
This incident affected: Amazon Web Services (AWS) (us-east-1).