Usage API is not returning data for usage after July 18 13:00 UTC

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Jul 19, 2025 - 16:45 UTC

Update

We are backfilling the missing data.
Posted Jul 19, 2025 - 16:25 UTC

Update

We are backfilling the missing data.
Posted Jul 19, 2025 - 16:08 UTC

Update

We are backfilling the missing data.
Posted Jul 19, 2025 - 15:42 UTC

Update

We are backfilling the missing data.
Posted Jul 19, 2025 - 15:19 UTC

Identified

Usage API is not returning data for usage after July 18 13:00 UTC
Posted Jul 19, 2025 - 15:15 UTC
This incident affected: Global Services (Cloud Ops API, Billing).