Namespaces in aws us-west-2 experiencing increased latencies

Incident Report for Temporal

Resolved

Latencies appear to have recovered
Posted Oct 22, 2025 - 02:15 UTC

Investigating

We are currently investigating this issue
Posted Oct 22, 2025 - 01:51 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).