Increased latencies in the aws eu-central-1 region

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 12:08 UTC

Monitoring

A remedy has been applied and we are monitoring the situation
Posted Aug 18, 2025 - 12:03 UTC

Investigating

We are currently investigating this issue.
Posted Aug 18, 2025 - 11:12 UTC
This incident affected: Amazon Web Services (AWS) (eu-central-1).