Some customers in AWS eu-west-1 may experience elevated latencies

Incident Report for Temporal

Update

Remediation has improved overall latency. We continue to monitor while the remaining work completes.
Posted Aug 05, 2026 - 17:29 UTC

Update

The remediation work is still in progress. Next update will be posted once this completes.
Posted Aug 05, 2026 - 16:05 UTC

Identified

The issue has been identified and remediation work is ongoing. API latencies might remain elevated while work completes.
Posted Aug 05, 2026 - 13:24 UTC

Investigating

Customers in AWS eu-west-1 might have experienced degraded API latencies starting 07:00 UTC.
Posted Aug 05, 2026 - 13:17 UTC
This incident affects: Amazon Web Services (AWS) (eu-west-1).