Services running hot in US-E-1

Incident Report for Temporal

Resolved

Note that the system had no errors; this was due to pure demand spike. Performance has returned to nominal levels, we will watch carefully as always.
Posted May 15, 2025 - 16:12 UTC

Update

We have added capacity, performance has improved, and we are continuing to monitor.
Posted May 15, 2025 - 16:04 UTC

Investigating

Some customers may experience higher-than-usual latencies
Posted May 15, 2025 - 15:47 UTC
This incident affected: Amazon Web Services (AWS) (us-east-1).