Delay in modifications of Authorization settings

Incident Report for Temporal

Resolved

A fix has been deployed
Posted Mar 02, 2026 - 06:39 UTC

Identified

Some users may experience delays in updates to their authorization settings. Authorization continues to work normally, however propagation of changes is being delayed.
Posted Mar 02, 2026 - 05:53 UTC
This incident affected: Global Services (Auth(n)/Auth(z)).