Some users experience https://cloud.temporal.io being slow to load or unavailable

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted May 26, 2023 - 22:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 26, 2023 - 18:32 UTC

Investigating

We are currently investigating this issue.
Posted May 26, 2023 - 16:16 UTC
This incident affected: Amazon Web Services (AWS) (ap-northeast-1, ap-southeast-1, ap-southeast-2, ca-central-1, eu-central-1, eu-west-1, eu-west-2, us-east-1, us-west-2).