Increased latency in region us-west-2

Incident Report for Temporal

Resolved

The issue is resolved and service is operating normally.
Posted Sep 27, 2026 - 01:53 UTC

Monitoring

Between 00:32 and 01:03 UTC, some namespaces in AWS us-west-2 saw increased API latency and errors. This has now recovered and we are monitoring.
Posted Sep 27, 2026 - 01:22 UTC

Investigating

We are investigating increased latency and errors for namespaces in AWS us-west-2. We will share another update within 30 minutes.
Posted Sep 27, 2026 - 01:01 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).