Latency issues in US EST

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Dec 03, 2021 - 16:36 UTC

Monitoring

A change has been deployed, latency has improved, and we are monitoring.
Posted Dec 03, 2021 - 15:39 UTC

Investigating

We are currently investigating this issue.
Posted Dec 03, 2021 - 14:30 UTC
This incident affected: Amazon Web Services (AWS) (us-east-1).