Some customers in GCP us-east4 may experience elevated latencies

Incident Report for Temporal

Resolved

API latencies have recovered and remained stable since the observed periods of elevated latency.
Posted Jul 22, 2026 - 13:04 UTC

Update

We are investigating short periods of elevated API latency that occurred between 11:58–11:59 UTC and 12:17–12:19 UTC.

We will provide an update as soon as it becomes available.
Posted Jul 22, 2026 - 12:48 UTC

Investigating

We are currently investigating elevated API latencies in GCP us-east4
Posted Jul 22, 2026 - 12:35 UTC
This incident affected: Google Cloud Provider (GCP) (us-east4).