Some customers in AWS us-west-2 may experience elevated rate of API errors and latencies

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 21:20 UTC

Investigating

Some customers in AWS us-west-2 may experience elevated rate of API errors and latencies.
Posted Jul 17, 2025 - 21:15 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).