Customers in GCP us-east4 are experiencing elevated latency for Visibility API calls

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 20:09 UTC

Monitoring

Latencies have returned to normal levels. The team is actively monitoring.
Posted Oct 06, 2025 - 19:58 UTC

Investigating

We are currently investigating the issue
Posted Oct 06, 2025 - 18:54 UTC
This incident affected: Google Cloud Provider (GCP) (us-east4).