Audit logs temporarily delayed for a few hours — no data loss.

Incident Report for Temporal

Resolved

This has been fixed, and the audit logs have been backfilled.
Posted Jun 11, 2026 - 20:45 UTC

Identified

We have identified that audit logs have been temporarily delayed since approximately 2026-06-11 18:00:00 UTC. We are implementing a fix, and we expect no data loss and a completed backfill within hours.
Posted Jun 11, 2026 - 19:58 UTC
This incident affected: Global Services (Audit Logging).