Usage data for replicated namespaces delayed

Incident Report for Temporal

Resolved

The backfill has completed, and the issue is resolved.
Posted Aug 02, 2025 - 07:00 UTC

Update

We are backfilling the missing data, estimate to complete in about 20 hours.
Posted Aug 01, 2025 - 16:28 UTC

Identified

We have identified an issue which has caused usage data for replicated namespaces to be delayed starting on 2025-07-24. We are working to correct the issue and will backfill the missing usage data.
Posted Aug 01, 2025 - 01:23 UTC
This incident affected: Global Services (Billing).