Some customers in AWS regions may experience delays in visibility task processing

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 00:20 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 11, 2025 - 22:13 UTC

Monitoring

Latency in AWS regions are returning to normal, we are continuing to monitor the situation.
Posted Jun 11, 2025 - 20:50 UTC

Update

We are continuing to investigate this issue. Workflow execution is unaffected.
Posted Jun 11, 2025 - 20:45 UTC

Investigating

We are currently investigating this issue. Workflow execution is unaffected.
Posted Jun 11, 2025 - 20:28 UTC
This incident affected: Amazon Web Services (AWS) (ap-northeast-2, ap-south-1, eu-central-1, eu-west-1, eu-west-2, us-east-2).