Some customers in AWS us-west-2 may experience unjustified throttling errors

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 16:25 UTC

Investigating

Some customers in AWS us-west-2 may experience unjustified throttling errors.
Posted Jul 09, 2026 - 16:08 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).