Some customers in AWS us-west-2 may experience elevated latencies

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 02:59 UTC

Monitoring

A fix has been implemented and we are monitoring the result.
Posted Feb 26, 2025 - 02:58 UTC

Investigating

Some customers in AWS us-west-2 may experience elevated latencies related to visibility task processing. The core system is not impacted.
Posted Feb 26, 2025 - 00:31 UTC
This incident affected: Amazon Web Services (AWS) (eu-west-2).