Some customers in aws us-west-2 may experience elevated visibility persistence latencies.

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 02:01 UTC

Monitoring

Latencies have returned to normal and we are monitoring the system.
Posted Apr 03, 2025 - 01:47 UTC

Investigating

Some customers in aws us-west-2 may experience elevated visibility persistence latencies.
Posted Apr 03, 2025 - 01:33 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).