Some customers in us-east-1 (AWS) may experience elevated API latencies

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 01:08 UTC

Update

We have resolved the original source of this problem, and are working to isolate the workflows involved, and will be contacting any affected customers with more specific information.
Posted Apr 23, 2025 - 01:07 UTC

Update

In addition, we currently believe a small number of workflows may be stuck. Research is ongoing.
Posted Apr 23, 2025 - 00:35 UTC

Investigating

We are currently investigating this issue.
Posted Apr 23, 2025 - 00:01 UTC
This incident affected: Amazon Web Services (AWS) (us-east-1).