Some customers in GCP us-east4 may experience elevated latencies

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 19:55 UTC

Update

The affected infrastructure has recovered. Latencies and error rates have returned to normal, and workloads have resumed.
Posted Jul 20, 2026 - 19:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2026 - 19:04 UTC

Update

A fix has been implemented and we are continuing to monitor.
Posted Jul 20, 2026 - 19:03 UTC

Identified

We have mitigated the primary impact, and service has been restored for most affected customers. Recovery efforts continue for the remaining infrastructure, with a small number of customer namespaces still affected. Our engineering team is actively working to complete restoration and will provide another update as progress is made.
Posted Jul 20, 2026 - 18:57 UTC

Investigating

We are currently investigating this issue
Posted Jul 20, 2026 - 17:44 UTC
This incident affected: Google Cloud Provider (GCP) (us-east4).