Service disruptions in AWS us-east-1

Incident Report for Temporal

Resolved

Update: Our systems are showing full recovery across all previously impacted namespaces. Namespaces that failed over during the incident have not yet been failed back. We are working directly with a small number of customers on follow-up recovery steps for issues indirectly related to this incident.
Posted Oct 20, 2025 - 19:30 UTC

Update

We continue to see recovery and are actively monitoring stability in the affected region
Posted Oct 20, 2025 - 19:00 UTC

Update

All pre-existing multi-region and multicloud namespaces to unaffected regions have been failed-over.

We are seeing major improvements in networking in the region. We will continue monitoring the situation until full recovery.
Posted Oct 20, 2025 - 18:35 UTC

Update

Investigating service disruptions due to ongoing AWS outage in US-East-1. See: https://health.aws.amazon.com/health/status

We are experiencing network instability in us-east-1. Some customers may see increased latency and error rates in this region.

We are currently failing over pre-existing multi-region and multi-cloud namespaces to unaffected regions.
Posted Oct 20, 2025 - 16:50 UTC

Update

Investigating service disruptions due to ongoing AWS outage in US-East-1. See: https://health.aws.amazon.com/health/status

We are currently seeing network instability in us-east-1. Some customers may see increased latency and error rates in this region.
Posted Oct 20, 2025 - 16:35 UTC

Update

Investigating service disruptions due to ongoing AWS outage in US-East-1. See: https://health.aws.amazon.com/health/status

We are currently seeing network instability in us-east-1. Some customers may see increased latency and error rates in this region.
Posted Oct 20, 2025 - 15:36 UTC

Monitoring

AWS is observing services recovering, see: https://health.aws.amazon.com/health/status

Workflow operations are currently not affected.
Posted Oct 20, 2025 - 10:22 UTC

Identified

Investigating service disruptions due to ongoing AWS outage in US-East-1. See: https://health.aws.amazon.com/health/status

There is a loss of OpenMetrics endpoint data for namespaces in us-east-1

Workflow operations are currently not affected.
Posted Oct 20, 2025 - 08:11 UTC

Update

Investigating service disruptions due to ongoing AWS outage in US-East-1. See: https://health.aws.amazon.com/health/status

Workflow operations are currently not affected.
Posted Oct 20, 2025 - 08:07 UTC

Investigating

Investigating increased latency in control-plane operations for some customers in AWS US-EAST-1 due to ongoing cloud operational issue. Workflow operations are not impacted.
Posted Oct 20, 2025 - 07:42 UTC
This incident affected: Amazon Web Services (AWS) (us-east-1).