Customers in us-east-2 may experience some visibility related errors

Incident Report for Temporal

Resolved

All MRN-enabled namespaces failed over by Temporal have been failed back. This incident has been fully mitigated and is now resolved.
Posted Jul 15, 2026 - 21:15 UTC

Update

We are seeing full recovery on our end, we are continuing to monitor.
Posted Jul 15, 2026 - 20:29 UTC

Monitoring

Mitigation is in effect, we are seeing some recovery. Please submit a support ticket if you are seeing service degradation.
Posted Jul 15, 2026 - 19:58 UTC

Update

Mitigation is still in progress. We are scaling up service to help with mitigation efforts.
Posted Jul 15, 2026 - 19:12 UTC

Update

All MRN-enabled namespaces have been failed over as of 17:53 UTC. Mitigation continues to progress.
Posted Jul 15, 2026 - 18:33 UTC

Identified

We are working on a fix, if your namespace are MRN enabled please fail over to your passive regions for faster recovery.
Posted Jul 15, 2026 - 17:52 UTC

Investigating

Customers with namespaces in us-east-2 may experience errors with visibility queries. We are currently investigating.
Posted Jul 15, 2026 - 16:55 UTC
This incident affected: Amazon Web Services (AWS) (us-east-2).