Customers in GCP us-central1 may experience elevated API latencies

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 05:09 UTC

Monitoring

An issue with the underlying cloud provider's network was identified. We are now seeing recovery and will continue monitoring.
Posted Aug 06, 2025 - 04:21 UTC

Investigating

We are currently investigating this issue.
Posted Aug 06, 2025 - 03:00 UTC
This incident affected: Google Cloud Provider (GCP) (us-central1).