Some customers in ap-south-2 (AWS) may experience elevated API latencies

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted May 29, 2025 - 18:01 UTC

Identified

A network issue has been identified by the cloud provider that is actively being investigated.
Posted May 29, 2025 - 17:39 UTC
This incident affected: Amazon Web Services (AWS) (ap-south-2).