Customers in GCP us-east4 may experience elevated API latencies

Incident Report for Temporal

Update

We are continuing to monitor for any further issues.
Posted Jul 08, 2026 - 00:05 UTC

Monitoring

We have rolled out a change and have paused further investigation overnight pending validation under daytime traffic.
Posted Jul 07, 2026 - 23:53 UTC

Update

We are continuing to work on the investigation and remediation of the elevated API latencies in GCP us-east4.

We will provide further updates within one hour.
Posted Jul 07, 2026 - 22:20 UTC

Identified

We are currently working to remediate the elevated API latencies that were observed in GCP us-east4.
Posted Jul 07, 2026 - 19:14 UTC

Update

We are continuing to investigate the elevated API latencies in GCP us-east4 and will provide more details as they become available.
Posted Jul 07, 2026 - 18:21 UTC

Investigating

Customers in GCP us-east4 may experience elevated API latencies.
Posted Jul 07, 2026 - 13:00 UTC
This incident affects: Google Cloud Provider (GCP) (us-east4).