High latencies being investigated in ap-south-1 region

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Aug 16, 2025 - 13:21 UTC

Monitoring

We have corrected the underlying issue and are seeing recovery.
Posted Aug 16, 2025 - 13:02 UTC

Investigating

We are currently investigating this issue.
Posted Aug 16, 2025 - 12:30 UTC
This incident affected: Amazon Web Services (AWS) (ap-south-1).