Some customers in us-east-1 may experience elevated API latencies
Incident Report for Temporal
Resolved
This incident has been resolved.
Posted May 15, 2024 - 20:59 UTC
Monitoring
Latency issue is resolved, we are monitoring.
Posted May 15, 2024 - 20:30 UTC
Investigating
Customers in us-east-1 may experience elevated API latencies.
Posted May 15, 2024 - 19:10 UTC
This incident affected: us-east-1.