Some customers in the AWS us-west-2 region might notice a delay in the visibility API

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 12:40 UTC

Monitoring

We are seeing Visibility API latency improvements and anticipate an accelerating full recovery.
Posted Mar 12, 2025 - 11:55 UTC

Identified

The issue has been identified and we are working to scale the cluster further.
Posted Mar 12, 2025 - 11:35 UTC

Investigating

We are currently investigating this issue.
Posted Mar 12, 2025 - 10:36 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).