Low Rate of Namespace Create/Update Failures Across All Regions

Incident Report for Temporal

Resolved

The rollback of the affected service has completed. Namespace configuration changes will resume as expected.
Posted Sep 02, 2026 - 15:49 UTC

Identified

We have identified an issue where some customers may receive failures when creating or updating namespaces. We are currently rolling back the affected service. Temporal Cloud will ensure failures are manually retried.
Posted Sep 02, 2026 - 15:26 UTC
This incident affected: Global Services (Namespace Management).