GCP customers in us-east4 are experiencing elevated errors for Visibility API calls

Incident Report for Temporal

Resolved

Namespaces have been failed back to their primary region.
This incident has been resolved
Posted Jun 09, 2026 - 00:59 UTC

Update

The region has recovered — visibility calls are succeeding without errors. We are failing namespaces back in.
Posted Jun 08, 2026 - 23:18 UTC

Update

Multi Region Namespaces were failed over at 10:23 PM UTC
Posted Jun 08, 2026 - 22:42 UTC

Monitoring

A fix has been implemented and we are monitoring
Posted Jun 08, 2026 - 22:38 UTC

Investigating

We are currently investigating this issue.
Posted Jun 08, 2026 - 22:06 UTC
This incident affected: Google Cloud Provider (GCP) (us-east4).