Degraded experience in the us-east region for limited customers

Incident Report for Temporal

Resolved

The issue is resolved
Posted Jul 28, 2022 - 22:58 UTC

Update

Customers may experience higher latency during this incident
Posted Jul 28, 2022 - 22:48 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 28, 2022 - 22:32 UTC
This incident affected: Amazon Web Services (AWS) (us-east-1).