Some customers in us-west-2 experiencing increased visibility API latencies

Incident Report for Temporal

Resolved

Visibility system and APIs have recovered.
Posted Apr 15, 2026 - 11:15 UTC

Monitoring

Remediation has been applied and the visibility system is recovering. We are continuing to monitor.
Posted Apr 15, 2026 - 10:36 UTC

Update

We are continuing to investigate the increased visibility API latencies.
Posted Apr 15, 2026 - 09:41 UTC

Update

We are continuing to investigate this issue.
Posted Apr 15, 2026 - 09:12 UTC

Investigating

Workspace operations are functioning normally. Some customers experiencing increased visibility api latency.
Posted Apr 15, 2026 - 08:58 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).