Some customers in GCP us-east4 may experience elevated API latencies and error rates

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Sep 22, 2025 - 23:37 UTC

Investigating

Some customers in GCP us-east4 may experience elevated API latencies.
Posted Sep 22, 2025 - 23:00 UTC
This incident affected: Google Cloud Provider (GCP) (us-east4).