Some customers using cloud ops API may experience higher latency and elevated rate of API errors

Incident Report for Temporal

Resolved

This incident is resolved
Posted Mar 11, 2026 - 23:53 UTC

Monitoring

A fix has been deployed and we will continue to monitor
Posted Mar 11, 2026 - 23:27 UTC

Identified

Some customers using cloud ops API may experience higher latency and elevated rate of API errors
Posted Mar 11, 2026 - 23:23 UTC
This incident affected: Global Services (Cloud Ops API).