We are investigating increased latencies/error rates in the AWS ap-south-1 region

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 14:03 UTC

Monitoring

The fix has been rolled out and we are seeing recoveries to latencies/errors
Posted Mar 27, 2025 - 13:49 UTC

Update

The hotfix is currently being rolled out to the impacted cluster
Posted Mar 27, 2025 - 13:19 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 27, 2025 - 13:08 UTC

Update

We are continuing to investigate this issue.
Posted Mar 27, 2025 - 13:08 UTC

Investigating

We are currently investigating this issue
Posted Mar 27, 2025 - 12:55 UTC
This incident affected: Amazon Web Services (AWS) (ap-south-1).