Namespace creation and modification availablity degraded

Incident Report for Temporal

Resolved

This incident has been resolved. Analysis shows the error was from our domain management vendor.
Posted May 22, 2026 - 23:43 UTC

Investigating

Namespace creation, modification and deletion had increased latencies from 23:10 to 23:35 UTC.

There is no impact to workflow operations
Posted May 22, 2026 - 23:40 UTC
This incident affected: Global Services (Namespace Management).