Data returned from the Usage API is delayed

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 12:46 UTC

Monitoring

The data has been caught up and we are monitoring the situation
Posted Aug 12, 2025 - 11:48 UTC

Identified

The Usage API is currently not returning any data after 2025-08-11 17:00:00Z. We are currently remediating the situation
Posted Aug 12, 2025 - 05:18 UTC